Jump to content


Photo

Rust Server Setup help?

config rcon rsm oxide rust

  • Please log in to reply
1 reply to this topic

#1 Mathieu

Mathieu

    Gamer

  • Members
  • Pip
  • 1 posts

Posted 17 January 2019 - 06:25 AM

Okay, so I could really use some help. For the passed few days I've been working on a Rust server for me and a few friends, although I haven't even been able to get to the portforward stage...

 

I've created a working .bat file (whether or not the settings/parameters are being read correctly is another story..), code down below;

 

echo off
:start
RustDedicated.exe -batchmode + D:\SteamCMD\steamcmd.exe +login anonymous +force_install_dir +D:\SteamCMD\rust +app_update 258550
+cfg cfg\server.cfg
+server.ip 127.0.0.1
+server.port 28015
+rcon.ip 0.0.0.0
+rcon.port 28016
+rcon.password "(changed for security purposes "
+rcon.web 1
+server.identity "server"
+server.saveinterval "600"
+server.tickrate 20
+server.seed 55
+server.worldsize 4000
+server.maxplayers 15
+server.hostname "Pleeblia"
+server.description"*Can you survive the end of civilization?\n*Or will you fall like a coward and let this world Eat you.\n*Discover new weapon and armour Blueprints along your travels to aid your Adventure ...\n*Or have them taken by someone else"
-logfile gamelog.txt
-load
-quit

 

The internal save rate, the tickrate, the worldsize - all that jazz is working normally - however I can't seem to save any of the RCON commands I use in the cmdprompt or the RustConsole itself (e.i. Bradley.enabled 0, ai.think 0 etc, etc). Are these commands to be defined in server.cfg? or the batch file created before running the dedi-console itself?

 

** I've managed to get Oxide working/running with the server

 

The server name is always stuck on Amsterdam II, and the description is stuck with some sort of loop bug repeating a brief summary of what you'd put in the description. 

 

If anybody has any idea what might be wrong, please get back to me ASAP!

P.S, have a feeling as though my /cfg files aren't setup correctly.. as every time I've entered RCON commands & tried to server.writecfg, nothing saves after restarting the server.



#2 Overlord

Overlord

    Pro Gamer

  • Members
  • PipPip
  • 105 posts
  • LocationArkansas

Posted 23 January 2019 - 10:54 AM

Okay, so I could really use some help. For the passed few days I've been working on a Rust server for me and a few friends, although I haven't even been able to get to the portforward stage...
 
I've created a working .bat file (whether or not the settings/parameters are being read correctly is another story..), code down below;
 
echo off
:start
RustDedicated.exe -batchmode + D:\SteamCMD\steamcmd.exe +login anonymous +force_install_dir +D:\SteamCMD\rust +app_update 258550
+cfg cfg\server.cfg
+server.ip 127.0.0.1
+server.port 28015
+rcon.ip 0.0.0.0
+rcon.port 28016
+rcon.password "(changed for security purposes "
+rcon.web 1
+server.identity "server"
+server.saveinterval "600"
+server.tickrate 20
+server.seed 55
+server.worldsize 4000
+server.maxplayers 15
+server.hostname "Pleeblia"
+server.description"*Can you survive the end of civilization?\n*Or will you fall like a coward and let this world Eat you.\n*Discover new weapon and armour Blueprints along your travels to aid your Adventure ...\n*Or have them taken by someone else"
-logfile gamelog.txt
-load
-quit
 
The internal save rate, the tickrate, the worldsize - all that jazz is working normally - however I can't seem to save any of the RCON commands I use in the cmdprompt or the RustConsole itself (e.i. Bradley.enabled 0, ai.think 0 etc, etc). Are these commands to be defined in server.cfg? or the batch file created before running the dedi-console itself?
 
** I've managed to get Oxide working/running with the server
 
The server name is always stuck on Amsterdam II, and the description is stuck with some sort of loop bug repeating a brief summary of what you'd put in the description. 
 
If anybody has any idea what might be wrong, please get back to me ASAP!
P.S, have a feeling as though my /cfg files aren't setup correctly.. as every time I've entered RCON commands & tried to server.writecfg, nothing saves after restarting the server.


Server description may not be working because of no space between +server.description and ".
adding a server image header will add an image above the description use +server.headerimage "link to image"
The Amsterdam II is the default image for when Rust cannot find the server.





Also tagged with one or more of these keywords: config, rcon, rsm, oxide, rust

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users