Welcome to The Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies and more

Sign in to follow this  
Ryan Pennington

How to add Admin

Recommended Posts

- Login to your server.

- Type /whoami

- Note the ID that appears in chat

 

- Login to the FTP for your server instance

- Navigate to the Configs folder of your server instance

- Download and edit the Users.eco file

- You need to update the Admins section to look similar to the code snip-it below.

- You will be replacing the "12345678901234567" with the ID that appeared in chat when you ran the /whoami command.

  "Admins": {
    "$id": "4",
    "System.String": {
      "$type": "System.Collections.Generic.List`1[[System.String, mscorlib]], mscorlib",
      "$values": [
                "12345678901234567"
      ]
    }
  },

- If you need or want to add multiple admins you need to ensure all but the last ID entry has a comma at the end of the line.

  "Admins": {
    "$id": "4",
    "System.String": {
      "$type": "System.Collections.Generic.List`1[[System.String, mscorlib]], mscorlib",
      "$values": [
                "12345678901234567",
                "76543210987654321"
      ]
    }
  },

- Upload the file back to your server instance's configs folder and overwrite the existing file if asked.

- You will need to update this config file every time you update the server.

Share this post


Link to post
Share on other sites

When i do this,
Then Push Restart. it do not work.

Then i Push "Save settings and restart server"
Then The  User.eco File gets overwritten by this
____________________________

{
    "MaxSlots": "20"
}


____________________________

Other files i edited in Config folder is not Overwritten,

Another thing,
i do not have ECO on Steam, So i only get an SLG Code..by doing /whoami  not the steamID64 code.
 

Share this post


Link to post
Share on other sites

Yes thanks
After some testing, i do see the problem and i did get it to work. By just adding SteamID in the original USER.eco file from my personal Server folder.
Well...
The File is not getting replaced anymore.. in other words, This would work for anyone having Steam connected to there ECO Game.
Alternative, 
Downloading the file from the FTP and only adding steamID64 as explained in your post.
____________________________________________________________________________________________
Tho... if one do not want there ECO Game on Steam,
How do one become Admin when the SteamID64 is not connected?
As i was saying, if i do,  /whoami = i get an SLG_code.

 

Edit : Ok.. Same process as with the SteamID64 . Just Add the given SLG_code.

as displayed when doing /whoami

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this