Welcome to The Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies and more


XML is not saving in FTP


yaboiiii
 Share

Recommended Posts

Hi!

I stopped the server, created the "Mods" folder (checked the version compatability), edited the server xml in FTP and booted. However, upon start up, its clearing my server xml settings everytime. This is problematic not just due to the settings, but also because EAC has to be deactivated for the mods to function.

The culprit I suspect is that i'm not properly saving the FTP session, (even though the mod changes i'm making are saving). So if theres any clarification, or any tips you all have, it'd be extremely appreciated.

Share this post


Link to post
Share on other sites

Just updating this, the mods and server are actually working! But the server xml didn't look like it was updated when I checked it prior. Does the server store its own version of the xml i'm updating everytime?

Share this post


Link to post
Share on other sites

After editing the serverconfig.xml, are you starting the server up using the "Start" button, or are you pressing the large green "Save Settings and Restart Server" button at the bottom of the control panel?

Share this post


Link to post
Share on other sites

  • 6 months later...

this is what was happening to me... in my case the permission that lets me delete files with FTP was turned off so i couldn't delete files (mods)... since uploading a new copy of the serverconfig file requires the system to delete the old one, if ya don't have permission to delete the old one the new one won't upload.  check and see if you can manually delete the file before uploading the new one... if not, you have to put in a support ticket and tell them to fix it... i've had to contact them over dozen times to get it turned back on.  this just started happening after the 20.6 update for me.

Share this post


Link to post
Share on other sites

  • 4 months later...

You are not properly saving the changes you are making to the server XML file in your FTP client. Make sure that you are using the "Save" or "Save As" function in your FTP client to commit your changes to the server.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share