Welcome to The Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies and more

Cannot Raise Max Level of Dino's - Using Annunaki Mod


leku200
 Share

Recommended Posts

I've created a ticket for this, but thought other players might be able to help as well  :wink:

 

Issue 1: Annunaki Genesis Mod (ID: 538986229) works on my server in all aspects  EXCEPT that the maximum level for Dino's are not raised as they should be by this mod. Despite this mod being active in the server, the max level for Dino's remain the same as in the base (vanilla) game.  

When working correctly, this mod should allow "the vanilla creatures to spawn between the levels 1 – 600"(source: Annunaki Genesis: Survivor Readme on Steam). Instead, Dinos can only be found at a max level of 120.  

I understand there are numerous posts on the Survival Server's forums concerning both the Annunaki Mod and the raising of max Dino levels. I've thoroughly read through each and every post related to these subjects (on Survival Server forums, Steam Workshop Forums, and throughout Google), as well as exhausting all proposed solutions to no success.  

My attempted solutions that failed: 
 

  • Wiping the server clean, removing Annunaki Mod, and resetting all Server Configurations to default. Afterwards, I re-installed Annunaki Mod to the server.
  • Wiping of the server of Dinos via EnableCheats --> SetCheatPlayer True --> admincheat DestroyWildDinos. Purpose for this was to remove all current Dinos from the server, allowing the server to repopulate with the updated and higher levels. Dinos repopulated at same vanilla levels. 
  • Using FTP to alter the Game.ini. The hierarchy of folders for this document was ShooterGame/Saved/Config/WindowsServer.
    • I added OverrideMaxExperiencePoints for both player and dino, set equal to experience points needed for the max level. 
    • I added LevelExperienceRampOverrides for both player and dino, set equal to all of the levels and their respective experience points. 
    • I added OverridePlayerLevelEngramPoints for the amount of player levels available (120 total levels). 


Solution I am aware of: Levels can be added via Game Server Control Panel --> Modify Server Config --> Dino Level Config --> Make Changes --> Adding Levels. I attempted this and I believe it would work, HOWEVER this method becomes extremely unhelpful when attempting to raise the Max Level to 600. Getting the custom Game.ini file to work with the server would be much more efficient. 

Solution I'd prefer: I'd like to be able to get the Game.ini file currently in the server's file to work. My modified version of the game.ini can be found attached to this post. 

Any suggestions are welcome! Let me know of anything else you need, and thank you for your time!   

Related Links: 
Dino and Player Levels
https://www.survivalservers.com/forum/index.php?/topic/1675-cant-increase-max-level/?hl=level&do=findComment&comment=14959
https://www.survivalservers.com/forum/index.php?/topic/2039-level-cap/?hl=level#entry11889
https://www.survivalservers.com/forum/index.php?/topic/1821-need-help-increasing-dino-and-player-levels/?hl=level

http://steamcommunity.com/sharedfiles/filedetails/?id=467912585
Annunaki
https://www.survivalservers.com/forum/index.php?/topic/2968-cannot-run-annunaki/
https://steamcommunity.com/groups/Annunaki_Ark/discussions/5/357288572116198252/

http://arksurvivalevolved.gamewalkthrough-universe.com/dedicatedservers/customizationtools/customlevelstool/default.aspx

Game.txt

Share this post


Link to post
Share on other sites

Does your GameUserSettings.ini have this at the bottom?

 

[/Game/Mods/Genesis/TestGameMode_Genesis.TestGameMode_Genesis_C]
OverrideMaxExperiencePointsPlayer=1000000000
OverrideMaxExperiencePointsDino=1000000000
 
 I was using Annunaki and I didn't have to alter/add any of the settings to get lvl 600. And your Game.ini is a little sloppy. Not being a dick or anything, it's just that Ark is picky sometimes.

Share this post


Link to post
Share on other sites

Sounds like you don't have annunaki loading in the #1 spot for mods.

 

 

Also, have you set your difficulty to 1?

Share this post


Link to post
Share on other sites

A big thank you for your help, snk and Vio!  :-D

 

I believe you're suggestions have fixed my problems (have started seeing dino's over level 120!)

 

Here's what I did that seemed to solve my problem: 

 

  • As per Vio's suggestion, I cleaned up my Game.ini. I simply let the "Update Settings and Restart Game Server" option wipe and replace my existing Game.ini.
  • I added the code Vio mentioned into my GameUserSettings.ini. 
  • Annunaki was the only mod I had active in the server, so load order wasn't the issue. However, I did impliment snk's suggest of "setting difficulty to 1". 

If anything janky related to this issue comes up again, I'll update this post. For now all seems well again!

 

Many thanks again for both of your help! 

 

For anyone who may experience this problem, here's a link to my now working 

Game.ini (nothing special, default settings)- http://pastebin.com/pzt45CNU

GameUserSettings.ini (Includes code for Annunaki Mod) - http://pastebin.com/H9hmGph6

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share