Welcome to The Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies and more

adding mods


DJFrost
 Share

Recommended Posts

I have added mod ids to the control panel box, and they are not loading in the world. Support relaunched my server due to some issues I was having, and the mods didnt appear to load since that restart. I have looked in the instal folders via ftp and none are showing the mods, and the mod folder is empty. Other than adding mods seperated by commas in the control panel box, is there anything else I need to do in order to install the mods? 

Share this post


Link to post
Share on other sites

I also have this problem. Got a list - looks right in the control panel, looks right in the SpaceEngineers-Dedicated.cfg

 

log file only shows :

2020-05-16 05:07:07.660 - Thread:   8 ->  MyDefinitionManager.GetSessionPreloadDefinitions() - START
2020-05-16 05:07:12.960 - Thread:   1 ->     Downloading world mods - START
2020-05-16 05:07:12.960 - Thread:   1 ->     Downloading world mods - END

Mod folder is empty.

Share this post


Link to post
Share on other sites

After some more reading and rummaging, it seems the <Mods> section does not copy from the SpaceEngineers-Dedicated.CFG to the Sandbox_config.sbc; the Dedicated is used to create the new 'save'/'world', but apparently doesn't properly inject the Mods XML line correctly into the Sandbox_config.sbc. 

I've tried to manually place the <Mods> segment in both the Sandbox.sbc and the Sandbox_config.sbc without avail. They always come back as just a  <Mods /> with no variables in both files. Something is lost in translation.

    </PlayerToFactionsVis>
  </Factions>
  <Mods />
  <PromotedUsers>
    <dictionary>

Not sure if this is a Engine issue or a Host issue.

Share this post


Link to post
Share on other sites

Placed a ticket with Support. They may have a script that modifies that config - to keep say your slots at the number where you paid for - so it my just be skipping over the segment, or borked.

Share this post


Link to post
Share on other sites

I was told by support that at the moment there is a problem having the mods added automatically through the control panel and you have to add them manually to the worlds cfg file. 

Share this post


Link to post
Share on other sites

About what I got. I've yet to try it. 

Quote

When this happens you can remove the Sandbox_Config.sbc and restart the server. This will then allow a new file to generate with the proper mods!

 

Share this post


Link to post
Share on other sites

Removing the sandbox_config.sbc seemed to do the same thing as if I tried to copying the spaceengineers-dedicated.cfg file and renaming it sandbox_config.sbc.

Log file shows several mods loading or trying to load.

I'll try to join the server later today and see if all's well.

 

Share this post


Link to post
Share on other sites

Have also been working on this .. for days...

 

WIthin the past week or two, I noticed that the server listings mostly all vanished.. then I notived a number of test servers that showed up. Now, within the list of servers to selct from, they have mostly all appeared again.

 

When I also put in a ticket on this, I was told the steps on how to list the server, which I did do.. however, it was how to list the server whint the Steam server listings - which I have literally have never seen before.

Anyways, it seems to me that something has happened with the official Keen server listings - maybe they are using different ports? 

Am not skilled in the type of programming that the sbc files use, else I would know what commands to use to 'listen' on ports 27000 thru 27015, from IP 0.0.0.0 (using the zeros is what allows 'listening' ). 



Prdon my typos.. am jinda burnt on this... besides, This is the 'Internet' so spelling is optionsal, right? : )

Anyways, perhaps it is not having the correct ports to communicate as to why there is not aut-downloading.. but when I add the MODs in a local game which I start & save in my computer, then everything works like a charm.  

 

THe next thing for me is, perhaps, to try to find what ports SE is using from my PC, then to change those values in the cfg or sbc file(s) herein. Maybe that is how to get survivalservers to communicate as my own computer is able to whenit gets MODs.

My lastest try to get MODs was adding:

  <Mods>
    <ModItem FriendlyName="Midspace's Configurable Max Ship Speed Mod">
      <Name>599536562.sbm</Name>
      <PublishedFileId>599536562</PublishedFileId>
    </ModItem>
  </Mods>

... which I got directly from my save file on my PC

 

..but it makes more sense now whythe MODs do not work for me - ofc they will not function until someone gets survivalservers to communicate in forder ot dowload the MOD files.  

I think maybe I'll try posting a public server from my PC, then see if I can find what ports are being used from them then copy into the dedicated server files.

Share this post


Link to post
Share on other sites

I should say that deleting the sandbox_config.cfg and letting it rebuild did correctly rebuild the sandbox_config.cfg and the Mods did download and install  - or at least tried. I have 1 that doesn't seem to be running.

 

 

6 hours ago, Achai said:

THe next thing for me is, perhaps, to try to find what ports SE is using from my PC, then to change those values in the cfg or sbc file(s) herein. Maybe that is how to get survivalservers to communicate as my own computer is able to whenit gets MODs.

I'm not sure what that means; you can find the IP and port of your game server on your control panel for survival servers. You dont need to know your local game information/ports.

 

 

6 hours ago, Achai said:

  <Mods>
    <ModItem FriendlyName="Midspace's Configurable Max Ship Speed Mod">
      <Name>599536562.sbm</Name>
      <PublishedFileId>599536562</PublishedFileId>
    </ModItem>
  </Mods>

I'm not quite sure if that format works for the dedicated servers. The SpaceEngineers-Dedicated.cfg looks something like this:

<Mods>
  <unsignedLong>1489569285</unsignedLong>
  <unsignedLong>1669459989</unsignedLong>
  <unsignedLong>1775277473</unsignedLong>
</Mods>

 

Share this post


Link to post
Share on other sites

It seems that all else is now functioning. 

Anyone have any word for  how long until the server provider will fix this issue?  I think the guy who is paying for the server am helping to admin might not wait past the weekend until we go elsewhere.

Share this post


Link to post
Share on other sites

I tried to add another mod to my server today; and tried the exact same method that worked a couple days ago - and it doesn't seem to work.

Tried it 3 different ways:

  • Created new world with new SpaceEngineers-Dedicated.cfg - no mods loading, no mods listed in sanboxes.
  • Stopped server, deleted the sandbox_config.sbc and restarted the server; wait for server to rebuild sandbox_config.sbc - no mods loading, no mods listed in sandboxes.
  • Stopped server, coped SpaceEngineers-Dedicated.cfg to Sanbox_config.sbc - no mods loading, no mods listed in sandboxes. 

Logs show its just not seeing the mods sections.

Aggravating. Updated my support ticket. 

Share this post


Link to post
Share on other sites

  • 3 months later...

I am having this problem as well, in exactly the same way described above.  The .cfg file has the mod files listed, but the .sbc files are not getting them/loading them into the game.  Is there a fix expected for this? 

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 8 months later...

Currently the web user interface does not work in my experience. Don't enter mods by a comma separated list. It does not work. Instead you manually need to edit Sandbox_config.sbc (save settings) and add the mods here. It works for me.

Step by step:

1. Don't try to add mods through web user interface. Stop the server.

2. Edit Sandbox_config.sbc (save settings) through FTP and add the mods with the new format - the one not using the unsignedLong element.

3. Start the server.

Share this post


Link to post
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share