Jump to content


Photo

How does the server create its restore points?

losing everything mods back up restore save restart

  • Please log in to reply
2 replies to this topic

#1 Vampireteddygram

Vampireteddygram

    Gamer

  • Members
  • Pip
  • 3 posts

Posted 03 February 2017 - 05:59 PM

I know things are kinda jacked up right now because of the Tek tier update, but I just want to make sure some of this is not user error. I have no problem with people telling me I am doing things wrong, I just want my server working correctly!

Wildcard is on a patching spree lately and I have been updating the server almost as soon as I can (don't know if this is the wrong thing to do.) and it is about a 50/50 chance that when the server comes back up we will have lost everything that came from a mod. At first I thought this was because of tek tier, but from what I have read it is because of Steam and mods not properly downloading. 

So, to combat this I have started checking the "skip mod updating" box. I haven't had to restart the server yet, but I feel like it should work. Unless one of the many many updates wildcard puts out breaks something again. I also disabled server restarting and am going to do it manually from now on. The restore points were only being created when the server was restarting which mine was set to every 24 hours. Which did not help much. I have the server set to Auto-save every 30 min, but it does not seem to create a back-up from this save. Does anyone know if this is a mistake or is this intended?

Just in case we lose everything again, how do you re install the mod and restore to try to get your things back? I removed the mod Id from the list restarted the server with the correct restore point, put it back in the list and restarted again with the restore point as well. Thinking it would grab a fresh download and fix the issue, but sadly everything was still floating in the air/ missing. What did I do wrong?

So, to wrap this whole thing up I just want to be sure I don't screw everything up tonight for my friends. When everyone gets off I am going to run a "admincheat saveworld" and then check "skip mod updating" and leave the update ark option disabled. When the server shuts down it should create a restore point right? If this is not the case I need to know how to manually create a restore point.



#2 Rawblin

Rawblin

    Gamer

  • Members
  • Pip
  • 37 posts

Posted 03 February 2017 - 07:41 PM

The backup restore option on the control panel page only gives you a restore point sporadically. To grab full control of this feature you want to log into your server with an FTP software (like Filezilla) and navigate to your Shootergame/Saved/SavedArk###/ Folder. Inside you will find the autosave entries listed out. They use some random time in the naming scheme, so I just look at the file modified time (which is based on my PC settings) to know when each backup occured.

 

To use any of these backup saves, simply change the name from TheIsland_whatevertime/date.ark to just TheIsland.ark (after saving your current TheIsland.ark to your local PC and then deleting said entry from the server.

 

Do this while the server is stopped btw, or things will get bad juju.

 

As far as the mod update issues.... make sure when you are restarting the server, whether it is manually or automatically, that you do NOT ever click another server altering command until the server is fully sitting at [Started] (Playernumber) [Ready] under server details in top left of screen. If you see [Loading] in yellow instead of the green ready, you CAN refresh the page to see if it is [Ready] yet (doesn't update on its own from what ive seen).

 

But if you click start, stop, reload, or save settings at any point before it is [Ready] you will usually kill a mod.

 

Hope that helps!



#3 Vampireteddygram

Vampireteddygram

    Gamer

  • Members
  • Pip
  • 3 posts

Posted 03 February 2017 - 09:26 PM

Thank you so much!







Also tagged with one or more of these keywords: losing everything, mods, back up, restore, save, restart

3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users